You are here: Home » Forum
BEHRINGER_Billboard-XD80USB
Results 1 to 8 of 8

Thread: Recording via Logic Pro

  1. #1

    Recording via Logic Pro

    HELP!!
    I've set up Logic Pro on my Mac and everything works perfectly - EXCEPT that I cannot get the backing track plugged in to my X32 usb to output via the xuf. It plays perfectly through the speakers and all of the mikes etc work perfectly via the xuf, it's just the backing track doesn't come through.

    I've tried setting the source for two of the unused inputs as the usb player - this sends a signal that is shown on the board and goes to the speakers, but does NOT get sent to the card.

    Any Ideas as to what I'm doing wrong?

    Thanks in advance,

    Gareth

  2. #2
    Super User Paul Vannatto's Avatar
    Join Date
    Dec 2012
    Location
    SW Ontario Canada
    Posts
    4,332
    Hi Gareth,

    The USB Player is the USB port on the X32. If you want to playback from the Mac, first you have to setup the routing to receive the signal from the Mac. That is specified in the Routing, Home screen. It is in either banks of 8 (for the first 4 sections) or a bank of 4 for the Aux In 1-4 (I use this). The latter will change the Aux 1-4 (3rd layer, left side) from Aux 1-4 (connected to back of X32) to Card 1-4 from the XUF.

    I don't know Logic Pro (I use Reaper), but there is probably something you have to do in there to route the output you want to the first 2 or 4 outputs of the ASIO driver.

    Paul

  3. #3
    Super User Paul Vannatto's Avatar
    Join Date
    Dec 2012
    Location
    SW Ontario Canada
    Posts
    4,332
    Better clarification of the first sentence. The USB Player is the USB port on the top of the X32 (where you install the firmware updates).

  4. #4
    Quote Originally Posted by Gareth Davies View Post
    HELP!!
    I've set up Logic Pro on my Mac and everything works perfectly - EXCEPT that I cannot get the backing track plugged in to my X32 usb to output via the xuf. It plays perfectly through the speakers and all of the mikes etc work perfectly via the xuf, it's just the backing track doesn't come through.

    I've tried setting the source for two of the unused inputs as the usb player - this sends a signal that is shown on the board and goes to the speakers, but does NOT get sent to the card.

    Any Ideas as to what I'm doing wrong?

    Thanks in advance,

    Gareth
    Hi Gareth,
    It sounds like you are using the USB Recorder port on the X32 to play your backing tracks and you want to record these tracks into Logic Pro. In order to record a signal that is coming from the USB Recorder via the XUF card, there are a few steps.

    1. Assign the USB signals to a pair of outputs on the "analog out" page of the ROUTING menu. For this example, use Outputs 1-2. Choose Output 1 and assign "dir out aux 7". Choose Output 2 and assign "dir out aux 8". Remember that you will need to chose the "tap point" you want, either pre/post fader or pre/post EQ.
    2. Page over to the "card out" tab, and choose "Out 1-8" one of your bank of 8 card outputs. If you did this in the last bank of 8 column, then the USB recorder would appear on Inputs 25 and 26 in Logic.
    3. If needed, you can assign the direct out of any channel to the remaining 6 analog outputs so that you don't need to use a whole bank of 8 simply on the USB playback.

    * Alternatively, if you aren't using the P16 system and don't have outputs to spare, you could use the steps above with the "P16 out" tab of the ROUTING menu and the "P16 out" options on the "card out" tab. You will notice when assigning this way, you will have the option to chose tap point for that direct out. This allows you to record channels to Logic, post X32 processing.

    Hope this helps, let me know if you need further clarification.

    Best,
    John DiNicola
    Senior Specialist, Product Support
    MUSIC Group
    BEHRINGER

  5. #5
    Super User Paul Vannatto's Avatar
    Join Date
    Dec 2012
    Location
    SW Ontario Canada
    Posts
    4,332
    Oops, I mis-read your post Gareth. Fortunately John has it all laid out for you.

    Paul

  6. #6
    Many thanks John - I'll give that a go when I get to work tomorrow!

    No problem Paul - actually, when I re-read my post, I could have worded it a little more clearly!!

    Thanks again to both of you for replying so promptly

    Best regards
    Gareth

  7. #7
    Thanks John - tried it today and it worked perfectly - you are a life saver!

    Just looking forward now to my S16 arriving (tomorrow) and then setting up our full rig.

  8. #8
    Quote Originally Posted by Gareth Davies View Post
    Thanks John - tried it today and it worked perfectly - you are a life saver!

    Just looking forward now to my S16 arriving (tomorrow) and then setting up our full rig.
    Hi Gareth,
    Happy to hear that you got it working!
    Thank you and congratulations on completing your rig with the S16. Reach out to us anytime if you have further questions.

    Best,
    John DiNicola
    Senior Specialist, Product Support
    MUSIC Group
    BEHRINGER

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •