You are here: Home » Forum
BEHRINGER_Billboard-XD80USB
Results 1 to 8 of 8

Thread: Re: Firewire problems losing sync with external host computer on new update Ver 1.10

  1. #1
    hyeatman
    Guest

    Re: Firewire problems losing sync with external host computer on new update Ver 1.10

    Hi All:
    With the new Update Release of 1.10 it is now possible to have direct control of the mic preamps independent from their channel assignment to allow inline recording mode and live card inserts. This allows the exciting possibilities of Audio Plug-ins running in an external host computer such as Wave's Multirack. I have built a dedicated Windows 7 64 bit PC Intel 2.8 ghz quad core with 32 GB of RAM specifically for this task. Multirack runs extremely well on this computer and I have connected this to the X32 via the Firewire 400 connection in the back of the mixer. Using the new Preamp page in the V1.10 I am able to get the live audio from the X32 to Multirack. The problem is trying to get the sound from Multirack back to the X32 without the Firewire losing sync and the audio sounding like the "attack of the Cylons". I have played extensively with the Berhringer firewire "Control Panel" software running on the PC and between all three sliders I have not had any success in keeping the firewire connection in sync between X32 and PC. Thinking that the onboard Firewire on the motherboard my not be suited for audio I purchased a separate PCIe Firewire card from SIIG which has been approved by Protools as the firewire card that works with all their audio hardware and software. The SIIG Firewire card produced the same poor results. Has anyone here in the form actually tried this loop from the X32 through an external computer and back to the X32 using Firewire? If so what would be the recommended settings in the software control panel for the firewire settings. Any thoughts or suggestions would be appreciated.
    Best,
    Hoyt Yeatman

  2. #2
    k4records
    Guest
    Hi Yeatman,


    this problem is well known, but at the moment there is no solution for this. Here we have written something about this:

    http://forum.behringer.com/showthrea...rewire-problem

    It seems, that this only happens on a Windows7 64-Bit system. On a 32-Bit the board is working very stable and well (I've tested this several times)


    I've posted this kind of problem in the Soundforums.net forum and Joe Sanborn (Behringer) told me, that he well search for a solution (several weeks ago). Here is my original post about this problem (I still have to test this issue with the new Firmware v1.11):


    I'm using the X32 for about two weeks now. It is a great board which is working fine - when I'm using it without a computer. When I'm using it with my Cubase 64-Bit I've got strange driver-problems. Here some details about my computer:

    Windows 7 64-Bit (German) with all updates (at least it should have all )
    Steinberg Cubase 6.0.7 64-Bit
    Behringer X32 Archwave Driver v5.25 (both Firewire and USB)
    Behringer X32 with Firmware v1.09 (it had v1.02 on delivery)
    Intel Core i7 processor
    NEC Firewire-Card (PCI) or VIA Card (onboard) [Windows 7 delivers "NEW" and "OLD" firewire drivers. I've tested both]


    some background:
    I'm using digital recording-interfaces for several years - so I'm not completely new to this. I've used a TASCAM US1641 (USB) and two Alesis MultiMix 16 Firewire for recording with Cubase 4 and Cubase 6 (the Alesis were daisy-chained to record 32 channels). I've never had problems with the drivers even at very low latency. So my computer-setup should be OK.


    Problem with Firewire:
    The first time I've connected the X32 by Firewire. I've got a good signal input but suddenly I've received strange noise on top of the signal. I've made a recording of this: you can download the file from here, because I'm not allowed to attache ZIP-files or MP3s here: noisyrecording. I had to increase the buffer-size to 40ms for each Input and Output - so I had 80ms turnaround-latency - but the noise is not the standard clicking, when the latency is too low so that the computer cannot manage it - it sounds like the board and the XUF has slightly different samplerates. OK, with this high latency it seems to work most of the time, but sometimes I have to change the buffersize several times to get the Firewire connection working. I've tried the firewire connection with an old Pentium M Notebook and everything was working - so it seems to be a problem with the 64-bit driver? I've tested with 32 in/32 out, 32 in / 8 out - same problem.

    In the old(!) behringer-forum someone has written about the problem I've figured out with firewire, too. He had this after flashing firmware version 1.09. Is this possible? Is this a known problem and is someone working on it? Can I help you in some way?


    Problem with USB:
    Then I've tried the USB-Connection. Here the latency can be much lower, but sometimes I've got strange readings within Cubase in the field "Clock source" (please have a look at the attached pictures). But the board was working. Strange, but OK if it is working, but: yesterday I tried to record our band but suddenly cubase showed me 64 inputs instead of 32. The Archwave drivers seems to be able to manage multiple X32, but here the driver seemed not to reset the list. I did not have time to check everything - I simple rerouted the cubase-inputs to input 33 to 64 and it worked, but this is not a solution.

    Some pictures of my setup (sorry for the german text):

    Here with strange characters within the field "Clock source". The characters (here "t - g") are changing if I change something within the driver-dialog:
    usbproblem.png

    and suddenly here it is working ("Computer" as Clock-Source) - until I change something in the setup-dialog of the driver:
    correct.png

    and here some pictures of the 64-inputs. As you can see, the clock-source is now "( - i":
    double_ins_and_outs1.png


    Minor Issue with XControl:
    I'm from Germany and I'm using a german character within my username. XControl starts with "IO ERROR" because it cannot access my home-directory which is name with a german "ö". I've solved this by creating a new username with only US-characters, but maybe it is easy to fix this for the next release


    Issue with Latency-Compensation on Cubase:
    On dub-recording I've figured out some problems with the latency-correction. Cubase automatically corrects the latency of the recorded material and moves the recorded audio on the timeline. For this Cubase takes the transmitted latency-information of the driver. I recorded some audio with lower latency, but Cubase moved the audio to much to the left, so it "over"-compensates the recorded audio. Maybe this problem is related to the problems above? I used the USB-connection for recording.


    Thank you very much for any help!


    kind regards,
    Chris
    Attached Images Attached Images

  3. #3
    k4records
    Guest
    Hi again,

    I've tested the new firmware v1.11 now and most of the problems still exists. With version 0.9 of the XControl now I'm able to start the application with my german user-name - great. But the problems with firewire (not in sync with board - it sounds terrible) and usb (wrong text in "clock"-display in cubase - but sounds well) are still there.

    Here are the four pictures which are missing in the above post:
    usbproblem.pngcorrect.pngdouble_ins_and_outs1.pngdouble_ins_and_outs2.png


    kind regards,
    Chris

  4. #4
    Hi Chris,
    the threadstarter droped me a pm and we could figure out his problems. So Hyot's system seems to work now and it is a 64bit, Win7 system too. Maye you should start all over again with chasing down the culprit. Have you run dpc latency checker and latency monitor? What are the results?

    http://www.thesycon.de/deu/latency_check.shtml

    http://www.resplendence.com/latencymon

    On your system, do you use Win7 with the Aero gui?

    Christian

  5. #5
    Hi Chris,
    the threadstarter droped me a pm and we could figure out his problems. So Hyot's system seems to work now and it is a 64bit, Win7 system too. Maybe you should start all over again with chasing down the culprit. Have you run dpc latency checker and latency monitor? What are the results?

    http://www.thesycon.de/deu/latency_check.shtml

    http://www.resplendence.com/latencymon

    On your system, do you use Win7 with the Aero gui?

    Christian

  6. #6
    k4records
    Guest
    Hi Christian,

    thank you very much for your assistance. The latency-check tells me, that the system is ready for a real-time calculation - so there are no dropouts (no yellow or red peaks).

    And yes, I'm using the Aero GUI. Do you think this could be a problem? With my two Alesis-Boards (both Firewire) this was not a problem. There I was using 32-channel-recording with low latency without problems.


    see you,
    Chris

  7. #7
    Hi Chris,
    that's good to hear. Just a few more hints:
    Maybe run latencymon in addition and see at the "driver" tab, if there are any processes rated with 1.0 or more...just to be sure. Aero might not be the culprit, why the sync is lost, but it is at least a CPU hog. Aero uses windows boarder padding and you should shut boarder padding off...always. Or just use the "classic windows theme" as default view instead, this does not use boarder padding.

    In addition I noticed a massiv performace boost on my DAW, when tweaking my windows with these tips-->
    http://www.softwareaudioconsole.com/...ng_Windows.htm

    I can go down to 48 Samples with the 32in/32out setting on the X32 and I just have an old Core2Duo E8500 CPU, 2GB RAM and Windows XP. You wrote, that you can go lower on USB than with Firewire on your PC. That's odd, I should be the other way round. What kind of Firewire card do you use? You wrote, it is a NEC PCI card. Is it really a PCI card, or a PCI(e) card?

    Most of the newer motherbords will use a bridge for the older PCI standard, that means, that this card will not perform that good. Only the PCI(e) cards have direct access to the CPU/Kernel.

    Nevertheless, it should have a Texas Instrument (T.I.) chipset or one of the newer Via. If you got a ricoh or a O2micro Firewire driver, you're screwed.

    Also maybe try this hotfix for firewire-->
    http://support.microsoft.com/kb/982669

    I will get my X32 back on Thuesday and I do have studio DAW with an i7 Sandybridge and Windows64 als well. I will check, if it works with the X32.

    Keep my fingers crossed!

    Christian

    BTW: If you prefere German windows tweaking tipps, this one is quite good as well imho:

    http://www.timos-welt.de/win7/Window...optimieren.pdf

  8. #8
    k4records
    Guest
    Dear Christian,

    thank you very much for your tipps. Yesterday I worked half of the day on my computer-setup. Now it seems to work with the firewire-connection but I cannot say which setting or part of the computer was the culprit. I've tested several settings out of your linked pdfs and reinstalled my old firewire-board tested it (was working well as expected) and removed it together with the drivers again. Before the changes LatencyMon or dplcheck confirmed me a perfect real-time-audio processing, so the problem was not a "classic" drop-out-problem.

    Now I can go down to 10ms in the XUF-Firewire-driver dialog without problems and go up again to e.g. 40ms. This was not possible at all before I changed the things.

    Well I hope this solved the problem with latency-compensation in Cubase, too. Now I can enjoy my X32 even more

    Now I'm using the following things (maybe helpful for people with the same problem):
    Windows7 64-Bit with 8GB DDR3-RAM (DualChannel)
    Cubase 6.0.7 64-Bit
    X32 Firmware v1.11
    Firewire-connection to an NEC1394-Card with 12ms Buffer
    XUF-Drivers v5.25 (Both USB and Firewire)


    Again: thank you very much for your help.


    kind regards,
    Chris

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •