You are here: Home » Forum
Results 1 to 4 of 4

Thread: Bugera 6262 help

  1. #1

    Bugera 6262 help

    Im not sure where to start but when I got this amp (used), it was one of the most amazing things i have tried, it has tones of gain.

    Now the power tubes decide to fail stock 6L6 (its ok, i've seen this alot even from other manufacturers), Then i got some replacement 6L6GC matched sets, loaded those in, biased according to the manual and its ready to go (44ma).

    Here's some points i can indicate

    • I noticed the 'Gain' is not quite there, it seems lacking and now
    • it does buzz
    • picking up radio (FM) transmissions , in both clean/dirt channel even if there is no guitar plugged in



    where it did not do that before. It's not my main gigging amp as i use a Bugera 1990,1960,333XL and V22 for live use.

    Hope you guys can share some insights

    Thank you

  2. #2
    Dear Bryan,

    Please feel free to contact our CARE team at care@music-group.com about these issues. If gain has been affected, it would sound like something relating to those specific tubes, but it's hard to say - there are many factors at play, and the technical guys should have the best understanding. Thanks, and good luck!


    Best regards,
    Sean Fairchild
    Specialist, Channel Marketing
    MUSIC Group
    BEHRINGER

  3. #3
    hello it was a phase inverter issue, solved

  4. #4
    Dear Bryan,

    Good to know! Thanks for reporting back - it can certainly help others in similar situations. Glad you're up and running normally once again!


    Best regards,
    Sean Fairchild
    Specialist, Channel Marketing
    MUSIC Group
    BUGERA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •