You are here: Home » Forum
Results 1 to 6 of 6

Thread: Problem with noise and quality.

  1. #1

    Problem with noise and quality.

    I bought this to provide a better connection with my PC. Now it's worse. Quality is suspect, and volume is less. And just how old is this piece of equipment?. Compatible with windows XP and 2000? No mention of windows 7 or 8. Not a happy chappy with my first Behringer purchase!

  2. #2
    Super User
    Join Date
    Dec 2012
    Location
    SW Ontario Canada
    Posts
    3,390
    Hi Russell,

    Welcome to the forum. Unfortunately you didn't explain what you bought or any details. So it is a bit hard to be of any help.

    Paul

  3. #3
    Sorry, I bought a U-PHONO UFO202 I get oscillating static interference thru the monitors.

  4. #4
    Super User
    Join Date
    Dec 2012
    Location
    SW Ontario Canada
    Posts
    3,390
    Hi Russell,

    Have you been on the UFO202 product download page? I see drivers for both 32 bit and 64 bit for Win7 and 8. I would suggest you download and install the correct driver for your computer and see if that solves the problem. Here is the link to the product page
    http://www.behringer.com/EN/Products/UFO202.aspx

    Paul
    Last edited by Paul Vannatto; 3 Weeks Ago at 05:18 PM. Reason: added product page link

  5. #5
    I installed new driver. Didn't make any difference.

  6. #6
    Is there a switch to select phono or line input?
    Can't tell from the picture on the site.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •