You are here: Home » Forum
Results 1 to 8 of 8

Thread: Problems setting up multiple BCF/BCR2000

  1. #1

    Question Problems setting up multiple BCF/BCR2000

    Hi there!

    I have a few problems with my set of B-Controls. I own 4 of them, at the moment: 2 BCF (white), 1 BCR and 1 BCF (blue). That's also the order in which I placed them on my desk in front of me, and I did that for a good reason!

    Speaking of reason... I use the latest version of Propellerhead's Reason (that would be v7.1) for music production, and I'd like to remote control several functions of the software with all those controllers as follows:

    -- The 2 white devices are supposed to grant me basic control over Reason's main mixer. (I think of having volume, panorama, stereo width, mute & solo and, maybe, one or two additional controls per channel mapped to those BCF.)
    It would be nice to have the 2 devices control 16 channels (8 channels on each device) either consecutive or independent from each other.

    -- Both of the blue devices are thought to control all of Reason's devices in the rack, as well as giving me full control over one complete channel strip respectively, when working in the mixer. These devices are already set up properly and mapped via Reason's remotemaps.

    And this is where my 1st problem occurs:
    The BCF is working properly and I'm completely satisfied with it. But the BCR is missing most of the feedback! None of the LED rings on the encoders will show any values -- neither do they show the actual "positions" of the controls, nor do they react on value changes (there's also no numerical feedback in the display). Reason receives those changes, though, and all the buttons will light up if pressing causes an according change in value.
    Funny thing is, when not synchronized with Reason (e.g. in Global Edit mode), all of the LEDs work just fine, so it's no technical defect, I think.

    2nd Problem is that I cannot use encoder groups on the BCR. Although I programmed them, the device won't let me select any but the 1st (which is always selected by default), and also won't indicate the selection by flashing the corresponding LED!

    I searched the internet and tried everything that came into my mind, but nothing would change. I even tried out the BCR of a friend with the same results!
    Does anyone know about this or have any idea how I could solve these 2 problems? I would be really grateful!

    Moving on, there are the two white devices, causing problem #3:
    I have set them up as described in the manual as well as in the few tutorials available (details added further down). They connect with reason properly (in the Control Surfaces window), and I can lock them to the master section of the mixer, but somehow I cannot get them to control any of the channels. I once managed to get it right, but then it was all the default functions of the .remotemap file. When I try to program my own file for those devices, it will be completely ignored, so I'll still have just the default functions.

    That's very annoying, and I'd be very glad (and moreso grateful) if there was someone to tell me how to deal with it, so that I can finally use my controllers as i had planned!

    THANKS IN ADVANCE for every hint that'll get me a step further to the goal!!!

    Here are some details about my setup:
    - PC, Core i7, 8 GB RAM, Win7ultimate, 64bit
    - Propellerhead's Reason 7.1
    - Focusrite Scarlett 6i6 (USB)
    - said BCF & BCR controllers
    - Nektar Impact LX49 master keyboard
    - additional keypad with 35 keys for controlling basic functions without using the regular
    - keyboard, mounted under the desk (extensible)
    - mouse
    - audio interface, keyboard and mouse all have their own USB (2.0) connections to the PC
    - the 4 BC's, Impact and the additional keypad are all connected via a powered 10-port USB (2.0) hub
    (the order is, as I remember: 1st/2nd come both of the blue devices, then those 2 white devices, the Impact and also the keypad. the latter 2 work just fine in this constellation!)
    Setup of controllers:
    - BCR............ USB mode 1 | Channel 1 | ID: 2
    - BCF (blue)... USB mode 1 | Channel 2 | ID: 1
    - BCF (white). USB mode 1 | Channel 3 | ID: 4
    - BCF (white). USB mode 1 | Channel 3 | ID: 3

    If you have any further questions, feel free to ask!

  2. #2
    Super User Paul Vannatto's Avatar
    Join Date
    Dec 2012
    SW Ontario Canada
    Hi Benjamin,

    Welcome to the forum. Wow! I wish everyone would provide that kind of detailed post when asking troubleshooting questions. I'm mostly involved with the X32 section where we frequently get a simple paragraph of the problem, and I guess it is expected that we use our crystal ball to discern the model/firmware/software, etc. in order to help. So kudos on your post.

    Unfortunately, I have no experience or knowledge of this hardware or Reason. But I will do a bit of looking to see if I can be of any help. Also I will poke Sean Fairchild from Behringer to see if he can be of assistance. He has taken the responsibility of support for this section of the forum.


  3. #3
    Thanks a lot, Paul!

    I think, the main reason, why I provided so much detail is because I've been working on that problem for about half a year now, with still no solution. And as you may guess, I tried a lot of my own ideas an of those from the sparse information to be found in the web... So I wanted to raise the probability of someone coming up with new ideas!


  4. #4
    Dear Benjamin,

    Wow, that was quite a description! This gets into some deep operational territory for the BCF/BCR, and I'm sorry to say it's well past my depth. However, that's why we have an engineering team and the folks at CARE who should be able to actually test a similar scenario to see if they can offer any advice! If you haven't already, please contact our CARE team at or call at 702-800-8290 in the US. It's probably better to email so you can cut and paste your thorough set of details. And if you do get your questions answered and resolved, please do post back here so that anyone else (myself included) that may have similar questions will benefit from it!

    Best regards,
    Sean Fairchild
    Specialist, Channel Marketing Prosumer Division
    MUSIC Group

  5. #5
    Well, let's hope then, I'll get more help (at least ANY) from CARE than by using the support function from the Behringer website!
    I will tzry it out... wish me luck!


  6. #6
    Super User Paul Vannatto's Avatar
    Join Date
    Dec 2012
    SW Ontario Canada
    Yes good luck Benjamin. Wish there were others here with your setup. If CARE is able to solve your problem(s), would you mind posting the solution(s) here?


  7. #7
    Hey, Paul and Sean!

    My "success" so far: I had contact with CARE, but the only result is that HE (ADKINS Jem) has no idea how to help me because HE uses Ableton (NOT Reason), and HE thinks my problem was all about my DAW, but NOT about the controllers...
    I emphasized "HE" that much, 'cause HE gave me the feeling, he was the ONLY one working ar CARE, with no other colleagues HE could refer to.

    I finally ended up with some testing of my own ideas, finding out that probably, the issue was about my USB hub. (I switched my blue devices, and suddenly the BCR haf full functionality but the BCF had not - just as before, but the other way around...)

    Now, I have posted my problem - considering it might be the hub - in a facebook group in which I am administrator, and instantly, they had some really good ideas how I could fix it. One of which was to a) plug the USB connections DIRECTLY into my PC (because otherwise the BCR/BCF would try and generate the same port for both devices, leading to conflicts in signal flow!), and to b) hook up the second device(s) via MIDI cascade.

    I thought to have tried the latter possibility bevore (with the two white devices), but had the problem, that the chained device would not correctly send/receive data. Anyways, my latest problem is that as soon as I set up 2 devices - the blue BCR/BCF to begin with - according to the manual, Reason would offer me just one connection but with two ports for both, MIDI in and out.
    The only (not so) funny thing about this is that the second (chained) device is detectable via MIDI learn at port 1, but the first device (that one with the USB connection) is not detectable on neither port. And I also cannot assign port 2 to either of the 2 devices, because "the MIDI port may bein use by another application". I find this strange, because there's nothing running, which would ude MIDI in any form!

    But I'll keep on trying...



  8. #8
    Super User Paul Vannatto's Avatar
    Join Date
    Dec 2012
    SW Ontario Canada
    Thanks Benjamin for updating us. I've seen USB hubs being an issue with other (non-audio) setups. So that makes sense that it could be with your setup as well. I do have to commend you for your excellent troubleshooting skills. That cannot be learned easily. Usually you either have it or you don't.

    We will definitely keep these posts available here for others with similar issues in the future.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts